Re: icon theme configuration

Thx a lot.

With my version of gnomevfs, i don't have the gnomevfs-type binary but I found a
similar binary in the test folder of the gnomevfs sources (i'm using the CVS
HEAD version).

Anyway, the return type is application/x-compressed-tar so it's not the file
type reconition and i also already had set the XDG_DATA_DIRS var in my system.

Today just before reading your mail, i think I almost found the problem. I
installed gnome-control-center (including a global theme config for metacit,
gtk and icons) and when I tried to reconfigure the theme, I saw that the new
gnome take the theme name not anymore from the folder name of the theme
location (gnome and hicolor) but form the theme name in the index.theme file
(GNOME and HiColor).

I think that's why when I set the theme name directly in the gconf, i put gnome
and not GNOME.

So that's my idea. I didn't really tested it.



Quoting yo96aguc02 sneakemail com:


It's probably not the icon theme, it's probably the mimetype
recognition. Type something like:
gnomevfs-type /home/your-dir/a-file.tar.gz
(where /home/your-dir/a-file.tar.gz is a real file of course).

and it should come back and tell you lots of things about the file
including that it is of type:


If not, your mimetype identification is hosed.

I had the same problem, in my case I have gnome installed in a
non-standard place. Assuming the fully-qualified root dir
of your gnome installation is <gnome-dir> you need to set something like:


to get it to work. Maybe try setting these to the appropriate
<gnome-root>/share will work for you.
I set them in <gnome-root>/etc/gdm/Xsession.

I think when I tried to run nautilus from the command-line it output
something to stdout saying something like XDG_DATA_DIRS and
XDG_DATA_HOME are not set, blah blah blah, default to /usr/share blah
blah blah, but I didn't read it very carefully.

That's all I know, hope it helps!

Johan FISCHER |lists-and-general| wrote:


I recently installed the gnome CVS version and it almost works (see my other
message :)).

I have a configuration problem with nautilus which doesn't load the gnome theme and only the hicolor one. Because of that, all my icones are blank and it's a
bit hard to navigate.
I'm almost sure it's only a configuration problem.

I installed :
- gnome-mime-data, gnome-vfs and shared-mime-info for the mime detection and
 three work fine (the file properties in nautilus always indicate a good
- hicolor-icon-theme and gnome-icon-theme for the themes.
- nautilus.

I configured the following keys in gconf to the value 'gnome' :
/apps/nautilus/preferences/theme (deprecated but it doesn't hurt)

I'm also using metacity. The only bug could be a problem during the retrieve of
the icon_theme but since everything else work, it should work too.
A strace of nautilus indicate nautilus always try to open the hicolor theme in
/home/user/.icons and /usr/share/icons

Any idea ?


This message was sent using IMP, the Internet Messaging Program.


This message was sent using IMP, the Internet Messaging Program.

Attachment: binQXp8DpQpuX.bin
Description: PGP Public Key

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]