Re: External editor with parameters not working?

On Sat, 06 Dec 2014 03:14:38 -0800, Stevko <stevko stevko info> wrote:


I tried the following thing:
1) export EDITOR="emacs -nw"
2) mc
3) (with internal editor disabled) go to some file and press F4

This opens emacs with the file, however it does not open it in
terminal (which should be done with -nw switch) but in new window in
X. (as if it somehow ignored -nw). If I run the following in shell:

$EDITOR file

it opens file as expected. Why does mc not do that?

I tried setting EDITOR to "vim -R" and again when run from mc, it does
not honor -R switch.

I have version 4.8.12 (which comes from Fedora 21 package).


I am not subscribed to mailing list (so send replies also to me).
mc mailing list

Hello Stevko.

I recall being confounded by this very thing.

In my mc/ini file ($HOME/.config/mc/ini)
I have this:

[External editor or viewer parameters]
vi=%filename +%lineno
vim=%filename +%lineno
ed=+%lineno %filename
/bin/mo=%filename +%lineno
mo=+%lineno %filename
less=%filename +%lineno
joe=%filename +%lineno
more=%filename +%lineno

You can add the command line options here.
It seems mc doesn't *really* call $EDITOR.

Peace and Cheer

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]