Re: Zip support broken ?

On Mon, 26 Sep 2011, Paul Hartman wrote:

2011/9/22 Frédéric L. W.:
Slackware 13.37 comes with Midnight Commander and UnZip 6.0. When
I press Enter on a .zip archive, it does nothing. But when I do the same
on an archive with execute permission, like those mounted from an NTFS
partition, it returns

bash: ./ cannot execute binary file

I also compiled 4.8.0-pre2, but got the same results.

.rar archives work fine. And if I move the urar helper script, it returns

Inconsistent extfs archive
sh: /usr/local/libexec/mc/extfs.d/urar: No such file or directory

That's expected. But if I move the zip script, it still doesn't return
anything. I guess the script isn't even called.

Is the Zip support broken, or it's something on my end ?

The "file" command 5.07 had a bug where it cannot identify ZIP
archives. If MC uses "file" to identify the type, maybe it's failing.
(you can test by running that command yourself to see what it says).
If "file" can't identify ZIP, upgrade or apply the patch:

Thanks. It no longer reports "cannot execute binary file", but still doesn'r work with the archives.

I'll investigate it further, because I'm really pretty sure that it used to work with git in 2010, without applying any patches.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]