I use mcedit constantly, running it on an OS X 10.5.8 terminal to
numerous remote redhat 9 linux machines from within mc, and on
occasion invoked as mcedit (which I presume, as per the docs, is just
mc -e.).

On occasion, I run into a file with ^M at the end of a line in MCEDIT.

I can delete these one at a time if I position the cursor right on them.

I have tried many things to attempt and use the F4 global search and
replace, but nothing seems to work in the first field, the search
field. I would leave the replace field empty, because I want them

Regular expressions - no. ^M, no. The format string replace... I don't
even understand HOW you would use that to find a control character.
%015, no. \015, no. \r, no. %13, no. %0D, no. 0x0D, no. [^M], no.

There's a [^] field at the end of the line, but I can't seem to get to
it with tab, and the mouse flat out does nothing in an mcedit pane.

I've been to the documentation (hah!) and I've searched using Google. Nothing.

I know I can use sed, etc., to do this, but I don't always have
execute privileges in the directories I'm working in, because I'm in
remotely via SSH in one pane - the filesystem is remote.

Could someone take pity on me and tell me how it's supposed to work?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]