Re: mc 4.7.0pre3 support for .tlz archives

Paul Hartman wrote:
On Tue, Oct 27, 2009 at 3:21 PM, Paul Marwick <paulm waitrose com> wrote:
Paul Hartman wrote:
On Tue, Oct 27, 2009 at 2:40 PM, Paul Marwick <paulm waitrose com> wrote:
After a bit of a hunt, I found this in /etc/mc/mc.ext

# .tar.lzma, .tlz
      Open=%cd %p#utar
      View=%view{ascii} lzma -dc %f 2>/dev/null | tar tvvf -

:) I'm not exactly expert on mc regex, but I can't see what the problem
I also tried renaming a .tlz to .tar.lzma. After doing this, no problem
opening it, and no problems with mc not recognizing it as a compressed

Can anyone see what the problem is? Anyone reproduce the problem?

:) Even better, any suggestions as to a fix that works?

Do you have the program "lzma" on your system? (I think lzma is
probably a symlink to xz nowdays)
Yes, I have /usr/bin/lzma, which is a symlink to xz. As I mentioned, if the
file is renamed from .tlz to .tar.lzma, it can be opened correctly, so the
system must be finding lzma. So I think the error must be in the regex used
to support the .tlz extention. I just can't see it...

Ah, sorry about that, I mis-read it.

No problem. Sorry about sending email direct - didn't realise that this list doesn't have Reply-To set. I'll have to keep an eye on that one...

I think I can see the same problem now. I just tried to rename a
file.tar.lzma (which MC opened normally) to file.tlz and MC told me it
"doesn't look like a tar archive". However, when I manually ran the

lzma -dc file.tlz  2>/dev/null | tar tvvf -

it listed the file's contents as you would expect. md5sum of both
files are identical.

That sounds like exactly the problem I'm seeing. Its not life threatening <g>, but it is a pain, since both Vector and Zenwalk have used .tlz packages in the past, and are only slowly moving to .txz.

I assume that it must be an error in the way the regex is structured, but I certainly can't see it.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]