Re: Meta-o does what again?


I notice with some happiness that someone has already brought this question up, and I can reply in a thread instead of opening a brand-new one.

Me, I recently patched my Slackware-11.0 because of some security bulletins, and one of the patches broke my then-currently-installed Midnight Commander, which had previously been working very well. Suddenly, I started to get error messages flashing up, which said that I cannot enter a certain directory, and I would get bumped back to $HOME, and such. It cured the problem when I went over to the slackware-current tree and borrowed the source file from there and installed it from source, compiling with the Slackbuild script, then installing the resulting package. After this, Midnight Commander worked again. However, I noticed immediately and with some irritation the behavior which has already been described in this thread. Namely, Alt-O no longer opens the same directory in the opposite panel, but now gives me the directory above it.

The problem, as I see it, is more or less like this:

Judging from what I read already in this thread, it seems that there is a belief that the behavior of Alt-O was somehow "broken" because it was not doing what the developers had been intending, all along (inspite of the fact that AFAICT it was doing all along what the documentation said all along that it was doing, as quoted in one of the letters in this thread already). That's one side of the issue. OTOH, I am a user who has grown accustomed to the previous behavior over a time interval of more than ten (10) years that I have been using Midnight Commander and I have used that feature on a regular basis. It does things that I find convenient and it makes my work go faster. And, most especially, I am used to it. Thus, when someone suddenly gets around to fixing an old "bug" it thereby disrupts my work flow every time that I have to remember that it is now "fixed." That is frustrating. It seems to me that what was fixed was not broken.

Me, I think Alt-O it was working just fine the way it was. I don't _want_ to go and "browse" some directory. I already know where my files are. What I want to do instead is to get work done without having to re-learn what I learned to do almost without conscious thought, over the last ten years. So for me, I am very sorry, your improvement or bugfix about this is not an improvement. I would be very glad if anyone can send me a patch which puts this back the way it was. I am sorry if I have come on too strong, but this morning the aggravation just got to be too much, so for this reason I sought out your website, checked the mail archives to see if anyone else had experienced this new, weird behavior and had already asked about it, and when I had read what was there, I subscribed to the list in order to write this.

Also, if I am making anyone unhappy who is reading this because he feels his efforts to improve a good product are being slighted, please keep in perspective that I have been a very satisfied user of Midnight Commander from the first time that I installed Linux, sometime around 1995. I have tried other file browsers and file managers and like none of them so well. So you who took the trouble to write this program must have been doing something right. If I never used this product I would not be writing this, after all. But, on the contrary, I find it to be without substitute.

As I said, please send me the patch, or direct me to the patch, which will fix this. And tell me, to which particular code I should apply it -- which version number or whatever. If you like, go ahead and specify code from your CVS or SVN tree and not a release version. That would be fine with me.

Theodore Kilgore

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]