Re: Midnight Commander jibberish in X windows

The problem is solved on my RH 8.0 now, 
i did env -i TERM=xterm-xfree86 mc
and the strange symbols were gone when i browsed some binary files with the 
internal editor, however, when i logged  (over ssh) in my self-compiled 
system the glitch was there. I did like this:
# env -i ssh void
void# env -i TERM=xterm-xfree86 mc

how is that possible ?

thats what env displays in mc:
bash-2.05a# env

On Tuesday 22 October 2002 21:21, Pavel Roskin wrote:

Problem: When I view a binary file with the internal MC editor (F3),
scrool up and down with PGUP and PGDOWN and then press F3 again to exit,
both panels are full with unrecognisable characters.  I took a

I think that telnet or ssh or whatever you are using propagates your
locale settings (usually LANG environment variable) to the remote machine.
And the remove mc cannot work in that locale.

In particular, locales using UTF-8 encoding are not supported.  They are
not supported even by the current version, let alone 4.1.35.  Set LANG to
something sane, like C, en_US or lv_LV, or even unset it.

The same problem is with the man pages. When I do man bash for example,
I get the strange symbols again if I scrool up and down.

It's all problems of Red Hat 8.0, even if you login to some other machine.
They are pushing UTF-8 to the console, and that leads to many problems.
They may be doing a good thing in the long term, but in the short term
it's a big headache.

The problem doesn't exist if I ssh to another PC with RH 7.2 for example
and run MC on that comp.

Of course.

I tried to install a different version of MC, same results. I also tried
to compile it with --with-ncurses then with a different version of glib,
no changes

Unfortunately, UTF-8 support is not implemented and I don't think it will
be implemented any time soon.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]