4.6.0-pre1: cant disable ncurses

[Disclaimer: I'm not on the list. Feel free to Cc: me, I'll try to read
the mail archive though.]

Hi there,

I just saw the mc-4.6.0-pre1 announcement and tried to build it on
Solaris 2.6. I have (non-native) ncurses and slang installed on the
machine. But I can't get this version to use either its internal or my
system slang, I can't even do "--without-ncurses", ncurses always gets
found and used. Interestingly enough, a directory no/lib and no/include
is being used. ;-) Reason: configure.in checks only "if test x$withval
!= xyes", and assumes if it's not "yes" I'm sending, it's a path. But
I'm sending "no", because I'm using "--with-slang=/my/path" and
"--without-ncurses", the latter equaling "--with-ncurses=no".

All other macros have a proper:

if test x$withval != xno; then
  if test x$withval != xyes

it's just missing for ncurses.

A patch is attached, proved to work here for the one configuration I
have now tried. (The patch only wraps the macro into "if test x$withval
!= xno; then [...]; fi"; it's blurred by indentation, sorry.)

"Works for me", mc in color again :-),
thanks for listening,

Attachment: mc-4.6.0-pre1-disable_ncurses.patch
Description: Text document

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]