RE: Fail to perform configure on solaris 8

Hi, Pavel!

That's great! Now we know that the old versions indeed have problems
finding glib.

In fact also last version failed first to perform configure - but it gave
very explisit message - LD_LIBRARY_PATH dose not contain shared library of
glib - so I fixed it and after this everything worked fine....

I see.

Maybe subshell is guilty. Try "mc -u".

You are right - it was the reason - with this flag it works , but what dose
it mean? Something in .cshrc hinder him?

I don't know. What shell are you using? By the way, run "ps" while mc is
hanging - you'll see what shell it is running.

The subshell code is quite complicated. I believe it has not been well
tested if the shell is not bash and the OS is not GNU/Linux.

If you want you could try to debug it, but be prepared that you may need
to attach the debugger to a running process instead of running mc from it.

Pavel Roskin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]