Re: files > 2G under Solaris

Unfortunately, simply adding AC_SYS_LARGEFILE to doesn't work
(RedHat Linux 7.1, i686) - I'm getting the same error "File XXX exists but
can not be stat-ed"

I'll try to fix it - if it works for me I'll make a snapshot for testing.
I'm still not sure if largefile support is good for everybody. Maybe I'll
fix AC_SYS_LARGEFILE so that it can be off by default.

Fixed! The problem was with some VFS sources doing bad things with

This file should always be included before system includes. Otherwise,
some of the definitions (in this case _FILE_OFFSET_BITS) in it won't have
any effect.

Considering possible compatibility issues and performance on low-end
systems (i386, i486sx) I decided not to enable large file support by
default, but now it should be easy to enable it.

Please take the latest snapshot from
and compile it with the following commands:

./configure CFLAGS="-g -D_FILE_OFFSET_BITS=64 -Wall"

Please report the results.

Pavel Roskin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]