Re: GNU Midnight Commander 4.6.2-pre1


I have tested this release and it does seem to remedy the search bug in the internal editor. Thanks.

I do have one other question, though. You noticed, probably, that I tried just now to answer someone's question about how to use the extension file in MC. I hope I answered his question, but here is one of my own, given rise to by what I just sent to the other gentleman.

To write my reply to him I mouse-copied something from another window. Here is the actual result of the mouse-copying, which I edited afterward to make it look decent.

#<----->Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (gqview %f &); fi
<------>Open=if [ "$DISPLAY" = "" ]; then zgv %f; else (/usr/bin/display %f &);
#<----->Open=display %f.
<------>View=%view{ascii} identify %f
<------>#View=%view{ascii} asciiview %f

Notice the <------> things in what I just copied? Well, I edited them out in the other letter, just now.

I can kindof see why this was introduced. Presumably, it is an indication that the TAB key has been used while the file from which I copied was being written. But I am not sure if this is a desirable feature, or not. I can easily think that, if I want to copy a block of C code from one file to another using the mouse, I would feel quite frustrated if this is what actually happens with every line where the tab key got used.

Another example follows, an excerpt from libgphoto2/camlibs/digigr8/library.c opened with F3 (view)

{"Vivitar Vivicam35", GP_DRIVER_STATUS_EXPERIMENTAL, 0x2770, 0x905c}, {"Praktica Slimpix", GP_DRIVER_STATUS_EXPERIMENTAL, 0x2770, 0x905c}, {"ZINA Mini Digital Keychain Camera", GP_DRIVER_STATUS_EXPERIMENTAL, 0x2770, 0x905c},

        {"Pixie Princess Jelly-Soft",    GP_DRIVER_STATUS_EXPERIMENTAL,
0x2770, 0x905c}, {"Disney pix micro", GP_DRIVER_STATUS_EXPERIMENTAL, 0x2770, 0x9050}, {"Suprema Digital Keychain Camera", GP_DRIVER_STATUS_EXPERIMENTAL, 0x2770, 0x913d},

OK, I was viewing the file, not editing it, so it seems that all worked as it should. Now I open the same file with F4 and copy approximately the same lines...

<------>{"Nexxtech Mini Digital Camera", GP_DRIVER_STATUS_EXPERIMENTAL, 0x2770,.
{"Vivitar Vivicam35", GP_DRIVER_STATUS_EXPERIMENTAL, 0x2770, 0x905c}, {"Praktica Slimpix", GP_DRIVER_STATUS_EXPERIMENTAL, 0x2770, 0x905c}, {"ZINA Mini Digital Keychain Camera", GP_DRIVER_STATUS_EXPERIMENTAL,. <--><------><------><------><------><------><------> 0x2770, 0x905c},....
        {"Pixie Princess Jelly-Soft",    GP_DRIVER_STATUS_EXPERIMENTAL,.
<--><------><------><------><------><------><------> 0x2770, 0x905c},.... {"Disney pix micro", GP_DRIVER_STATUS_EXPERIMENTAL, 0x2770, 0x9050},. {"Suprema Digital Keychain Camera", GP_DRIVER_STATUS_EXPERIMENTAL,. <--><------><------><------><------><------><------><------>0x2770, 0x913d},

You see what I mean? Ouch. If this were a real piece of C code I would really be having fun now, wouldn't I?

I guess there are times when it might be nice to have this as a feature. I can not think of any, but I am sure that somebody thought it is a good idea. So it would be really nice if there is a way to turn this on or off at will. Or, maybe, it was not such a good idea in the first place. It must be in some syntax file, but which and where?

Incidentally, I must also say that I am not sure where this all came from. I was previously using the standard Slack 12.0 package called


which had the search bug in it.

Another place I saw a dramatic difference was in looking at a Makefile. One used to see there a bar of red if a line started with a tab. Now, it is the <----------> thing again. So it looks weird if one was accustomed to the other way. And, again, to copy with the mouse leads to funny-looking things happening which it seems to me ought not to happen.

Comments? Suggestions?

Theodore Kilgore

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]