Midnight commander

Title: Midnight commander

I have been a very happy user of midnight commander for many years.  I have never had any problems with it.  Now we are upgrading our hardware and moving to a new server.  On our old server we are running MC 4.5.42.  For the new server, I went to your website and downloaded the latest version MC 4.6.0.  We installed it on the new server but when we try and execute it, we get the following message:

$ mc                                                                   
/usr/lib/dld.sl: Can't open shared library: /usr/local/lib/libslang.sl
/usr/lib/dld.sl: No such file or directory

We thought maybe we were missing some libraries so we checked the dependencies and made sure we had them all installed.  But we still get the same error.  I have checked this path and the library is not there.  I checked the same path on our old server and the library doesn't exist there either. 

Here is what I got from running gdb mc core

$ gdb mc core
HP gdb 5.4.0 for PA-RISC 1.1 or 2.0 (narrow), HP-UX 11.00
and target hppa1.1-hp-hpux11.00.
Copyright 1986 - 2001 Free Software Foundation, Inc.
Hewlett-Packard Wildebeest 5.4.0 (based on GDB) is covered by the
GNU General Public License. Type "show copying" to see the conditions to
change it and/or distribute copies. Type "show warranty" for warranty/support.
warning: Load module /usr/local/bin/mc has been stripped

(no debugging symbols found)...
Core was generated by `mc'.
Program terminated with signal 6, Aborted.

(no debugging symbols found)...#0  0xc0040e78 in kill+0x10 ()
   from /usr/lib/dld.sl
(gdb) where
#0  0xc0040e78 in kill+0x10 () from /usr/lib/dld.sl
#1  0xc004098c in raise+0x24 () from /usr/lib/dld.sl
#2  0xc0035ecc in fatal_error+0x50 () from /usr/lib/dld.sl
#3  0xc0018d78 in finish_dld_main+0xedc () from /usr/lib/dld.sl
#4  0xc0015658 in _dld_main+0x1c8 () from /usr/lib/dld.sl
#5  0xd36c in <unknown_procedure> + 0x4e4 ()
#6  0xc9ac in <unknown_procedure> ()
#7  0xc004098c in raise+0x24 () from /usr/lib/dld.sl

So…any ideas where this library comes from or what I need to do to get MC running on our new server?

Any suggestions would be appreciated.


Brenda Sauve
bsauve pnm com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]