Command line history button bugs?

It's a good thing to read help and manuals. I always wanted to know what the [^] thing at the right bottom corner of the screen was. I have disabled the keybar and in such way it seems that the button is useless.

Apart from that, the button has a weird behavior when switching things on and off. It moves one space left so the ] thing stays there twice or when you open the editor.

a) When configured with hidden menu and key bars, MC starts with the command line history button at the bottom right corner of the screen/window.
If the keybar is made visible, the ']' piece stays there.
If the keybar is hidden again whe have the ']]' piece twice
as the button is moved left.
b) With hidden keybar, that button is useless. It seems to me that the keybar is still getting all mouse events.

No clue for the first one. For the second I tried to reduce the size of the "invisible" keybar when there's a command prompt:

--- layout.cMon Aug 5 18:06:44 2002
+++ /home/dmartin/src/ Aug 9 00:36:49 2002
@@ -676,7 +676,7 @@
widget_set_size (the_prompt-widget, LINES, COLS, 0, 0);

- widget_set_size (the_bar-widget, LINES-1, 0, 1, COLS);
+ widget_set_size (the_bar-widget, LINES-1, 0, 1, COLS-((command_prompt !keybar_visible) ? 4 : 0));
the_bar-visible = keybar_visible;

/* Output window */

Of course, that's with the latest snapshot and Mandrake 8.1 with kernel 2.4.18. Tried in Linux console and Konsole. (BTW, for FXX functions I have to press F(XX-2) key, in both places)

*8-) David

Join Excite! -
The most personalized portal on the Web!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]