Re: /tmp names
- From: Pavel Roskin <proski gnu org>
- To: Pavel Machek <pavel ucw cz>
- Cc: <mc-devel gnome org>
- Subject: Re: /tmp names
- Date: Mon, 11 Jun 2001 17:01:35 -0400 (EDT)
Hi, Pavel!
> >I suggest either using a fixed name like "vfstmp" in those two calls
> >or
> >changing the names of the5/5:361-7-ms to short values with no spaces,
> >i.e.
> >"fish", "mcfs" etc.
>
> Change the names to short ones.
Done. Make sure that the short names look good for you.
__________________________________
--- cpio.c
+++ cpio.c
@@ -613,7 +613,7 @@ static struct vfs_s_data cpiofs_data = {
vfs vfs_cpiofs_ops = {
NULL, /* next pointer */
- "CPIO dearchiver",
+ "cpiofs",
0, /* flags */
"ucpio", /* prefix */
&cpiofs_data, /* vfs_s_data */
--- extfs.c
+++ extfs.c
@@ -1129,7 +1129,7 @@ static int extfs_setctl (vfs *me, char *
vfs vfs_extfs_ops = {
NULL, /* This is place of next pointer */
- "Extended filesystems",
+ "extfs",
F_EXEC, /* flags */
NULL, /* prefix */
NULL, /* data */
--- fish.c
+++ fish.c
@@ -792,7 +792,7 @@ static struct vfs_s_data fish_data = {
vfs vfs_fish_ops = {
NULL, /* This is place of next pointer */
- "FIles tranferred over SHell",
+ "fish",
F_EXEC, /* flags */
"sh:", /* prefix */
&fish_data, /* data */
--- ftpfs.c
+++ ftpfs.c
@@ -1681,7 +1681,7 @@ static struct vfs_s_data ftp_data = {
vfs vfs_ftpfs_ops = {
NULL, /* This is place of next pointer */
- N_("File Transfer Protocol (ftp)"),
+ "ftpfs",
F_NET, /* flags */
"ftp:", /* prefix */
&ftp_data, /* data */
--- local.c
+++ local.c
@@ -295,7 +295,7 @@ local_which (vfs *me, char *path)
vfs vfs_local_ops = {
NULL, /* This is place of next pointer */
- "Local filesystem",
+ "localfs",
0, /* flags */
NULL, /* prefix */
NULL, /* data */
@@ -355,7 +355,7 @@ vfs vfs_local_ops = {
vfs vfs_nil_ops = {
NULL, /* This is place of next pointer */
- "Filesystem which just returns failure",
+ "nullfs",
0, /* flags */
NULL, /* prefix */
NULL, /* data */
--- mcfs.c
+++ mcfs.c
@@ -1120,7 +1120,7 @@ mcfs_setctl (vfs *me, char *path, int ct
vfs vfs_mcfs_ops = {
NULL, /* This is place of next pointer */
- N_("Midnight Commander's private remote filesystem"),
+ "mcfs",
F_NET, /* flags */
"mc:", /* prefix */
NULL, /* data */
--- sfs.c
+++ sfs.c
@@ -387,7 +387,7 @@ sfs_which (vfs *me, char *path)
vfs vfs_sfs_ops = {
NULL, /* This is place of next pointer */
- N_ ("Single file filesystems"),
+ "sfs",
F_EXEC, /* flags */
NULL, /* prefix */
NULL, /* data */
--- tar.c
+++ tar.c
@@ -519,7 +519,7 @@ static struct vfs_s_data tarfs_data = {
vfs vfs_tarfs_ops =
{
NULL, /* This is place of next pointer */
- "TApe aRchiver decompressor",
+ "tarfs",
0, /* flags */
"utar", /* prefix */
&tarfs_data,
--- undelfs.c
+++ undelfs.c
@@ -681,7 +681,7 @@ undelfs_init(vfs *me) {
vfs vfs_undelfs_ops = {
NULL, /* This is place of next pointer */
- N_("Undelete filesystem for ext2"),
+ "undelfs",
0, /* flags */
"undel:", /* prefix */
NULL, /* data */
__________________________________
Regards,
Pavel Roskin
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]