[guppi-list] Problems with guppi 0.40.0 and gnumeric (I think gnucash too)

I'm getting a crash in the guppi libs or guppi-gnumeric.  I haven't
figured out a good way to get a gdb backtrace of this yet.  Any
suggestions welcome.  Anyway.

I run guppi-gnumeric in an xterm.  It just pauses.  Then I run
gnumeric from the menu.  I press the little barchart icon on the
toolbar and a dialog appears.  I can choose any type of chart in the
top box without trouble.  But pressing Next gets me a gnome crash
notice box for guppi-gnumeric and the following messages.

In the xterm I get:
6 : guppi\ > guppi-gnumeric

guppi:gnumeric-CRITICAL **: file guppi-gnumeric-graph.c: line 860 (gup_gnm_graph_generate_series): assertion `manager->arrangement_len >= 1' failed.
<?xml version="1.0"?>
<graph:Graph xmlns:graph="http://www.gnumeric.org/graph_v1";>
      <Type xmlns:graph="http://www.gnumeric.org/graph_v1.dtd"; name="Bar">

guppi:gnumeric-CRITICAL **: file guppi-gnumeric-plot-bar.c: line 71 (bar_plot): assertion `series != NULL' failed.

and in .xsession-errors (from gnumeric I'd guess) I'm getting:
Bonobo-WARNING **: Could not open help topics file NULL for app gnumeric

** WARNING **: 'Unknown CORBA exception id: 'IDL:CORBA/COMM_FAILURE:1.0'' : while gettting graph DataGuru control

** CRITICAL **: file /extra/ray/gnumeric/gnumeric-0.74/build/../src/dialogs/dialog-graph-guru.c: line 700 (graph_guru_init_data_page): assertion `s->data_guru != CORBA_OBJECT_NIL' failed.

Obviously I'm doing something screwy since I'd see more screaming on
the ml about this.  Any suggestions appreciated.

Debian package info (shows libs linked to and their versions):
Package: libguppi13
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 2815
Maintainer: James LewisMoss <dres debian org>
Source: guppi
Version: 0.40.0-1
Replaces: libguppi8, libguppi9, libguppi11, guppi (<= 0.35.5)
Depends: bonobo (>= 1.0.14), gdk-imlib1, libart2 (>= 1.2.13-5), libaudiofile0, libbonobo2 (>= 1.0.14), libc6 (>= 2.2.4-4), libdb3 (>= 3.2.9-1), libesd0 (>= 0.2.22-4) | libesd-alsa0 (>= 0.2.22-4), libgal17 (>= 0.17), libgdk-pixbuf-gnome2 (>= 0.13.0-1), libgdk-pixbuf2 (>= 0.13.0-1), libglade-gnome0, libglade0, libglib1.2 (>= 1.2.0), libgnome32 (>= 1.2.13-5), libgnomeprint15 (>= 0.29-1), libgnomesupport0 (>= 1.2.13-5), libgnomeui32 (>= 1.2.13-5), libgnorba27 (>= 1.2.13-5), libgtk1.2 (>= 1.2.10-2.1), libguile9 (>= 1:1.4-17), libncurses5 (>= 5.2.20010310-1), liboaf0 (>= 0.6.7), liborbit0 (>= 0.5.12), libreadline4 (>= 4.2-2), libxml1 (>= 1:1.8.14-3), oaf (>= 0.6.7), python2.1, xlibs (>> 4.1.0), zlib1g (>= 1:1.1.3)
Conflicts: libguile9 (<< 1:1.4-7), libguppi8, libguppi9, guppi (<= 0.35.5), libguppi11
Description: Libraries for guppi.
 This contains the libraries used by the guppi program and useful for
 other programs.
 Guppi is a Gnome-based guile and python scriptable plot program with
 integrated statistics capabilities.
Need to work on the description a little as well I just noticed.  Any
suggestions about that also appreciated. (No guppi program now I

Can't think of any more info to include.


PS: These will eventually be the debian packages of guppi, but since I
haven't gotten them working yet I haven't uploaded.

@James LewisMoss <dres debian org>      |  Blessed Be!
@    http://jimdres.home.mindspring.com |  Linux is kewl!
@"Argue for your limitations and sure enough, they're yours." Bach

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]