Re: [guppi-list] major goose breakage coming soon to CVS

> * In some code, I've been careless in using size_t and unsigned
>   interchangeably.  This is causing problems on 64-bit platforms where
>   the two are not the same size.  I'm in the process of fixing this,
>   basically by removing all of the size_t types (which I find to be an
>   annoying type, anyway) that I can and replacing them by unsigned.
>   (For example, the size() of a DataSet is going to change from size_t
>   to unsigned.)

Would you please make that "unsigned int" rather than just "unsigned"?
I consider "unsigned" to be C style, rather than C++ style.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]