Murray Cumming wrote:
I think we should do this in C++ much as it is done in C: - We should have an add_watch(priority) that just causes the signal to be emitted. and - We should have an add_watch(slot) that provides a sigc::slot that is called. We have lots of these set_func(slot)-like functions in gtkmm. Hi. I'm trying to implement these GstBus "watch" functions and I have a quick question. AFAICT, GstBus has the following "watch" functions: gst_bus_add_watch(GstBus*, GstBusFunc func, gpointer) gs_bus_add_watch_full(GstBus*, gint priority, GstBusFunc func, gpointer data, GDestroyNotify notify) gst_bus_add_signal_watch(GstBus*) gst_bus_add_signal_watch_full(GstBus*, gint priority) gst_bus_remove_signal_watch(GstBus*) As I understand, the first two will be wrapped using slots while the last three deal with enabling/disabling the Gst::Bus "message" signal. My question is: When these functions are wrapped, should similar names be used for the methods (eg. Gst::Bus::add_signal_watch() for gst_bus_add_signal_watch)? -Jose |