API question about RecentManager
- From: "Jonathon Jongsma" <jonathon jongsma gmail com>
- To: "Gtkmm Mailing List" <gtkmm-list gnome org>
- Subject: API question about RecentManager
- Date: Wed, 19 Jul 2006 21:33:39 -0500
I've got a question about the new RecentManager API. In the past,
many classes have used function overloading where GTK+ had to resort
to different function names because they had two similar functions
that took slightly different arguments. However, I noticed that
RecentManager has the following API:
bool add_full (const Glib::ustring& uri, const Data& recent_data)
bool add_item (const Glib::ustring& uri)
Is there any reason that we couldn't just name them both add_item? I
think I prefer function overloading instead of different function
names here. Anyone else?
--
jonner
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]