[gtkmm] gtkmm-2.2.0


I have recently installed the Gnome-2.2.0 libraries and gtkmm-2.2.0.  A 
program which previously worked with gtkmm-2.0.2 now fails when starting up 
with gtkmm-2.2.0, with the following message (the window eventually shows and 
buttons work, but no text appears):

"Cannot load module /opt/gnome-2.2/lib/pango/1.2.0/modules/pango-basic-xft.so: 
/opt/gnome-2.2/lib/pango/1.2.0/modules/pango-basic-xft.so: undefined symbol: 

This is with Gtk+-2.2.1, pango-1.2.1, freetype-2.1.3 and the Xft2 and 
fontconfig libraries which come with fcpackage-2.1.  Everything is compiled 
with gcc-3.2.1 and I am using binutils-

Gnome-2.2 itself seems OK (although I have not yet fully tested it), in the 
sense that fonts appear to show up correctly, and fontconfig/anti-aliasing 
work as they should.   Such of the gtk+-2.2 and gtkmm-2.2 examples as I have 
tried work normally.  So my set-up seems OK.

I get this problem even if I comment out all the (few) explicit calls that my 
program makes to pangomm.  The program does not use gnomemm (it just uses 
libsigc++-1.2.3 and gtkmm-2.2.0).  It compiles without error.

This is quite possibly a gtk+/pango problem rather than a gtkmm/pangomm 
problem, but before bothering the gtk+ list I wondered if anyone here had 
experienced similar difficulties with gtkmm-2.2?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]