Re: [gtkmm] get method inconsistencies



On Fri, 2002-08-02 at 00:49, Andreas Holzmann wrote:
> > > accelgroup.h    name()  -> get_name()
> > [snip]
> > 
> > What are these 2 columns? Is name() the current method name, and
> > get_name() your suggested method name?
> 
> Yes.
> 
> > Note that we use thing() rather than get_thing() when returning
> > references (or something that acts like a reference) instead of
> > by-value. For instance, with TreeModel::children().
> 
> Ah. Ok, I didn't know this.

So could you revise your review now that you know:
- accessors that return reference or reference-like things, such as
children() or signal_something() have no get_() prefix.
- methods such as empty() are intended to mimic the STL interfaces. In
particular, we _cannot_ change the ustring interface - it has to mimic
the std::string interface.

-- 
Murray Cumming
murrayc usa net
www.murrayc.com




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]