Re: [gtkmm] get method inconsistencies
- From: Murray Cumming <murrayc usa net>
- To: Andreas Holzmann <Andreas Holzmann epost de>
- Cc: gtkmm-list <gtkmm-list gnome org>
- Subject: Re: [gtkmm] get method inconsistencies
- Date: 01 Aug 2002 12:57:39 +0100
On Wed, 2002-07-31 at 23:47, Andreas Holzmann wrote:
> while looking at the menu accelerator API I noticed that there are
> inconsistencies in get_*-method names and is_*-method names in the
> Gtkmm library. The Gtk+ library uses get_foo() function names where
> get functionality is implemented and is_foo() when boolean result are
> expected. The Gtkmm library uses same names for wrapped functions (of
> course), but is inconsistent when new methods are implemented. This is
> (I think) because STL uses a different naming scheme.
> A quick scan through the sources:
> accelgroup.h name() -> get_name()
What are these 2 columns? Is name() the current method name, and
get_name() your suggested method name?
Note that we use thing() rather than get_thing() when returning
references (or something that acts like a reference) instead of
by-value. For instance, with TreeModel::children().
murrayc usa net
] [Thread Prev