Re: [PATCH v4] Add support for LED state extension to gvnc



On 05/09/2013 09:27 PM, Daniel P. Berrange wrote:
On Thu, May 09, 2013 at 09:22:19PM +0800, Lei Li wrote:
diff --git a/src/vncconnection.h b/src/vncconnection.h
index cbfefd7..cc07cfc 100644
--- a/src/vncconnection.h
+++ b/src/vncconnection.h
@@ -39,6 +39,11 @@ G_BEGIN_DECLS
  #define VNC_IS_CONNECTION_CLASS(klass) (G_TYPE_CHECK_CLASS_TYPE ((klass), VNC_TYPE_CONNECTION))
  #define VNC_CONNECTION_GET_CLASS(obj)  (G_TYPE_INSTANCE_GET_CLASS ((obj), VNC_TYPE_CONNECTION, 
VncConnectionClass))
+/* identical to the ledstate bits */
+#define VNC_SCROLL_LOCK_LED (1 << 0)
+#define VNC_NUM_LOCK_LED    (1 << 1)
+#define VNC_CAPS_LOCK_LED   (1 << 2)
It would be preferrable to use

     VNC_LEDSTATE_XXXXX

as the naming convention.

Sure.

Aside from that, this looks fine now.

Has the QEMU side of this been committed yet ? If not, I'll
wait until it has before adding this to gtk-vnc.

Hi Daniel,

Yes, patch series has already been upstream in QEMU a few days ago,
would be in QEMU release 1.5.

https://lists.gnu.org/archive/html/qemu-devel/2013-04/msg04990.html

I will update new version based on your suggestion above
very soon, thanks!


Daniel


--
Lei



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]