Re: [PATCH v4] Add support for LED state extension to gvnc



On Thu, May 09, 2013 at 09:22:19PM +0800, Lei Li wrote:
diff --git a/src/vncconnection.h b/src/vncconnection.h
index cbfefd7..cc07cfc 100644
--- a/src/vncconnection.h
+++ b/src/vncconnection.h
@@ -39,6 +39,11 @@ G_BEGIN_DECLS
 #define VNC_IS_CONNECTION_CLASS(klass) (G_TYPE_CHECK_CLASS_TYPE ((klass), VNC_TYPE_CONNECTION))
 #define VNC_CONNECTION_GET_CLASS(obj)  (G_TYPE_INSTANCE_GET_CLASS ((obj), VNC_TYPE_CONNECTION, 
VncConnectionClass))
 
+/* identical to the ledstate bits */
+#define VNC_SCROLL_LOCK_LED (1 << 0)
+#define VNC_NUM_LOCK_LED    (1 << 1)
+#define VNC_CAPS_LOCK_LED   (1 << 2)

It would be preferrable to use

    VNC_LEDSTATE_XXXXX 

as the naming convention.

Aside from that, this looks fine now.

Has the QEMU side of this been committed yet ? If not, I'll
wait until it has before adding this to gtk-vnc.


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]