GError not registered


I ran in a bug using Gtk3 and Gtk3::WebKit: when I get an error in some
case, I get an error "GType GError (#) is not registered with gperl"

my libglib is 2.36.3

I posted a testcase that can trigger the bug at any run :

Changing the request uri while there is a handler connected on
resource-load-failed trigger the bug.
I know the test case is a bit long, but I don't know how to trigger the
underlying error with less code.

Then running perl -CSD leads to
this message :

GType GError (25725440) is not registered with gperl at
/usr/share/perl5/ line 137.
 at line 10
        main::__ANON__('GType GError (25725440) is not registered with
gperl at /usr/...') called at /usr/share/perl5/ line 137
        Gtk3::main('Gtk3') called at line 76

In the real program, I get some random errors too.

Have you any ideas ?


NB: I sent this mail before via another address, but it didn't worked.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]