RE: installing Perl Gtk2 on windows xp

Thanks for the advice.
I did this:
- removing Gimp, and the Gtk2 run time files.

I reinstalled gtk-2.12.9 for win32

Using ppm I can see that the perl modules are installed.
Gtk2 version 1.141
Gtk2::Glade XML 1.006
+ a lot of modules in the Gtk2::Ex family

Running a perl script using Gtk2 gives the following error
(perl.exe:2672): libglade-WARNING **: unknown property `orientation' for class ` GtkVBox'

How can I solved this ? 

Since I have perl 5.8.9, I understand that the CamelBox binaries could be problematic ?

Downloading Bundle::Gnome2 with ppm and running the install command via CPAN perl -MCPAN -e 'install 
require the binaries of pkg-config, and so on, wich are not installed any more on my PC

Thanks for any help


-----Original Message-----
From: Brian Manning [mailto:elspicyjack gmail com] 
Sent: mercredi, 11. mai 2011 18:48
To: RAPPAZ Francois
Cc: gtk-perl-list gnome org
Subject: Re: installing Perl Gtk2 on windows xp

On Wed, May 11, 2011 at 5:36 AM, RAPPAZ Francois
<francois rappaz unifr ch> wrote:
I tried to run a Gtk2 based perl script on window xp with active state perl installed. Â(perl version is 
5.8.9) I use also mingw + dmake to compile from C.
I have download Gtk2 from
I have problem with Glib : the breaks with errors
1) a msgbox saying that a entrypoint in libglib-2.0-0.dll is not found

How many copies of the GTK stack (gtk+/glib/pango/cairo) do you have
installed on your machine?  I would say your perl script is finding
the wrong glib library.  Note that apps like Pidgin and Gimp for
Windows are sometimes bundled with their own GTK stack as well.

2) Can't find package gobject-2.0

I have gobject-2.0.lib in my gtk\lib folder and a gobject-2.0.pc in gtk\lib\pkgconfig. My PKG_CONFIG_PATH 
is C:\Prog\gtk\bin;C:\Prog\gtk\lib\pkgconfig

Can you run the pkgconfig command in the same shell that you set
PKG_CONFIG_PATH in and have it return the version for gobject?

XP-GTK-BUILDER# pkg-config --modversion gobject-2.0

If you can't run the above command, then your PKG_CONFIG_PATH is not
set or is set incorrectly.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]