Re: Gtk2::SimpleList crashes

muppet wrote:

Can you post a script and your software versions? I can't reproduce on my (rather ancient) system with this:

... I had to slightly rearrange your script so it can produce some output:
(with your script, there is no error message, just the segfault)

use Gtk2 -init;
use Gtk2::SimpleList;
print "Gtk2::VERSION              $Gtk2::VERSION\n";
print "Gtk2::SimpleList::VERSION  $Gtk2::SimpleList::VERSION\n";
print "Gtk2->GET_VERSION_INFO     ".join(".",Gtk2->GET_VERSION_INFO)."\n";
print "Gtk2->get_version_info     ".join(".",Gtk2->get_version_info)."\n";

my $slist = Gtk2::SimpleList->new ('Stuff' => 'text');

@{ $slist->{data} } = qw(one two three four five six seven);

my @data = @{ $slist->{data} };
@{ $slist->{data} } = @data;

Gtk2::VERSION              1.190
Gtk2::SimpleList::VERSION  0.15
Gtk2->GET_VERSION_INFO     2.12.11
Gtk2->get_version_info     2.12.12
Segmentation fault

As far as I can tell this happens in general on Debian "Lenny" (x86 and amd64);
On older systems that I tried, it worked. Obviously, the problem isn't really
in my code but somewhere else.

(In my original program I now, instead of trying to use grep on the list, first
calculate the indices of rows that I need to delete and then use splice;
a little clumsy, but it works ...)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]