package Glib::String is not registered with GPerl


I have the following problem:
I have a small Gtk2-application which runs fine with perl but whenever I try to pack it together in a .exe I run in to problem. The creation of the exe-file is no problem but when I run it (even on the same computer as the one with my perl/gtk environment is fully installed) I get this error: "package Glib::String is not registered with GPerl at script/ line 30"

And line 30 is "my $treemodel = Gtk2::TreeStore->new('Glib::String', 'Glib::Int');"

This is a win32-environment and the following things are installed
ActivePerl 5.8.8 build 822
Gtk+ Runtime Environment 2.8.20-1
ppms from (Glib: 1.142, Gtk2: 1.141)

After the exe-file is created, I put the exe in a dir with *.dll from gtk\bin and still it wont work. I've also tried to create a basic par-file which I've filled with files whenever there was complaints of files beeing out of @INC.

Any takes on this?



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]