Re: Gtk2::MozEmbed Segmentation Fault

On Fri, 2008-02-15 at 14:55 -0800, Brendon Mosher wrote:

Each time I run it I get a "Segmentation Fault (Core Dumped)" error.
I found a few posts in regards to this, but no solutions.  Anyone know
how to fix this?

I helped Brendon find the problem in irc, it was due to Gtk2::MozEmbed
being compiled with the package firefox-dev and not libxul-dev on ubuntu

With the previous ubuntu version (feisty) it worked with firefox-dev but
only if the firefox path was in either /etc/ or
LD_LIBRARY_PATH. Without it it would segfault.

And by the way, with xulrunner-1.9 (default for the future ubuntu
hardy), Gtk2::MozEmbed doesn't find the mozembed libraries.
It would be nice if it could be fixed. These pages may help :

And about fixing Gtk2::MozEmbed, a mostly the man page
Gtk2::MozEmbed::index.3pm generated by the compilation is mostly
empty/useless and its NAME line generate this warning by lintian :
N:   Each manual page should start with a `NAME' section, which lists
N:   name and a brief description of the page seperated by '\-'.

the '-' is missing.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]