Re: Gtk2::MozEmbed + DOM



On Sat, 26 Mar 2005, Scott Lanning wrote:
On Sat, 26 Mar 2005, Torsten Schoenfeld wrote:
Did you consider changing the names of the methods to match the rest of
the API (GetButton => get_button, for example)?  Studly caps don't occur
[...]
I didn't consider it, but I'll change them. [...]

Good thing, I found a bug. :)
(GetCharCode was aliased to itself instead of GetKeyCode.)
I've changed those now and also converted spaces to tabs.
I'll send the patch later after I do some more things.

I finally realized for the marshaller problem that I had
only done `make` and not yet `make install`, so the
old Gtk2::MozEmbed was being used. Duh, sorry!

Did you copy the signal documentation from somewhere?
I'd rather do that than try to guess what they do.
I couldn't find the text in the Mozilla source, though.
  I noticed some of the POD in GtkMozEmbed.xs is incorrect.
For example, =for only takes one "paragraph" and it must follow
the =for tag immediately (see `perldoc perlpod`). These should
be replaced with =begin and =end, if I'm not mistaken. Also,
I think blank lines are required after =cut, etc. Hm, the POD
generated seems okay, though. I shouldn't worry about it.
The POD generated for the dom event functions is messed up
though because they use ALIAS. I didn't look at that yet.

Finally, I didn't write any tests yet. But it's a four-day weekend,
so I have some time.

Something that worries me a little bit...
Gtk2::MozEmbed relies on gtkmozembed, in Mozilla. I heard
that Mozilla development will stop and Firefox will take its
place. I don't know if Firefox has the same gtkmozembed.
I looked in firefox-1.01 source, and it has an identical
gtkmozembed.h, so maybe there's no cause for worry. But I wonder
if we tried adding nsIWebBrowser/contentDOMWindow stuff for accessing
the DOM, whether that would all be different in Firefox.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]