Re: Build problem Gtk2-1.037

On Monday 01 March 2004 10:49, Thierry Vignaud wrote:
we patch quite a lot of packages b/c of bugs, missing features,
security issues, ...

one can manually overwrite these with upstream releases and if he
shots itself in the foot, it's his problem.
this can happen with any package (kernel, glibc, kde, ...).

packaging exists for some good reason.

sane upgrade is to update package, not to gratuitously overwriting it
with manuall tarball rebuild.

I would have done it the 'right' way if I had found newer packages that had 
what I need. I made the mistake and assumed that Gtk2-perl was Gtk2-perl, and 
a newer version would be backward-compatible, unless it was a major upgrade 
(such as Gtk1 -> Gtk2).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]