Re: RFC version issues

On Fri, 2004-01-23 at 16:52, Brett Kosinski wrote:
* Ross McFarland <rwmcfa1 neces com> [2004-01-23 05:18]:
2) add two new functions, for example check_bound_version and
get_bound_version_info. these would return the versions Gtk2
was compiled against and therefore what is available to the

Sounds like the only logical option.

I would also say that it might be valuable if Gtk2-Perl emitted a runtime
warning indicating a mismatch between the version of Gtk compiled against
versus the version of Gtk detected at run-time, as this kind of scenario
strikes me as predominantly a user error (ie, broken dependencies between

this would actually be a pretty common case. install gtk2-perl, upgrade
gtk+ for some c app. that doesn't mean that we couldn't warn there, but
it really isn't a user error. if they have no apps that require newer
gtk2-perl, then there's no (undeniable) reason for them to have to


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]