Re: Gtk2::Spell tests

Gavin Brown said:
This is for Ross mostly, I think:

In testing Bundle::Gnome2 (version 0.04 of which I released today, by
the way), I found that 'make' failed for Gtk2::Spell.

The reason for this is that Ximian Desktop on Red Hat 9 prefers aspell
over pspell, and installs the pspell-compat libraries for applications
that use pspell. However, in order to have aspell, pspell and
pspell-devel must be removed. So I couldn't build Gtk2::Spell.

known issues, solutions unknown. this doesn't seem to be a problem on fedora
(~rh10) so that's good.

Removing aspell and installing pspell and pspell-devel solved this, and
Gtk2::Spell built with no problems. But when I came to run 'make test',
it failed with:

Gtk2::Spell->new_attach: pspell: Sorry, I can't read the file
"/usr/lib/aspell/british". at t/0.GtkSpell.t line 34.

Setting $LANG to 'C' solved this, but obviously pspell-compat is getting
in the way. I could remove pspell-compat, but that would break a lot of
stuff, for example Abiword.

There's obviously something wrong going on here - I think munging $LANG
would be a good idea in the test script, so that it doesn't try to load
a dictionary it doesn't have, but what about the build problems?

setting LANG in the test script sounds like an ok thing to me so that will be
commited here in a min.

all that aside i can't say that i'm too much of a fan of gtkspell after
looking at it for a while. (and having all of these issues pop up) apparently
there's something called gnome-spell that someone might ought to look into
binding as it seems a little more featured/robust/etc.

bascially the make problems are rh9's and not Gtk2::Spell's so there's not
much that can be done. i'll commit the fix to the lang thing, but to sum it up
i don't much care for gtkspell so i wouldn't be hurt if it wasn't in the
bundle in the first place.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]