Re: namespaces

Guillaume Cottenceau said:
"muppet" <scott asofyet org> writes:
- i mapped g_timeout_add to G::Timeout->add, g_idle_add to G::Idle->add,
g_io_add_watch to G::IO->add_watch, and g_source_remove to
G::Source->remove.  any better ideas?

that makes no big deal but in the pas "timeout_add" was used,
maybe keeping this would be easier for people? e.g.
Glib2->timeout_add or something of the like.


  sub timeout_add { shift; return G::Timeout->add (@_); }

and friends in for that very reason.  i hesitated to put them in
because the docs all say that the gtk-level functions (e.g. gtk_timeout_add)
are deprecated, but they are old, familiar, and easy.

muppet <scott asofyet org>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]