Re: libgnome-perl example code broken?

On Mon, 27 Nov 2000, Jake Hawkes wrote:
Luis Villa wrote:

marvin:~$ ./
Can't locate object method "init" via package "Gnome::Panel::AppletWidget"
at ./ line 8.

I know you dont want to hear this, but "It works for me".

Heh. Well, a response is better than what I got out of my last email to
this list so I'm happy :)
Things to check, version of perl-gnome package. For me, it is in


and more, shows
$VERSION = '0.7003';

$VERSION is 0.7004, so no that isn't it (unless there is a version
specific problem.) 

the other thing to make sure is that you are doing a 

use Gnome;

at the begining. I dont think `use Gtk;' will cut it for you...

in fact, I just tried the code with
use Gtk;

and I got the same error. My guess would be to use
use Gnome;

The code (both in the Debian package and in the source) uses
Gnome and not Gtk. Adding a "use Gtk;" so that it calls both also doesn't
help at all. Of course, commenting out the "use Gnome;" line also gives
the same result, as does trying "require Gnome;" instead. 

Additional data points: the script in the source directory seems
to show that everything is installed correctly- all the other Gnome
samples run fine. So, it shouldn't be an installation problem. The OS is
Debian, last night's woody, so Paolo is to blame somehow :) 

Anyway, thanks for the help, Jake- anyone else have any ideas as to what
might be wrong or how I can do more diagnostics? Thanks in advance-

      "Nobody ever said that democracy was simple or efficient."
            Florida Election Board Member Bob Crawford.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]