Re: [gtk-osx-users] issues.

Le 5 août 2018 à 05:50, John Ralls <jralls ceridwen us> a écrit :

On Jul 28, 2018, at 8:50 AM, Pascal <p p14 orange fr> wrote:


This week, I tried to build a fresh GTK-OSX build on macOS HS.
I'have got many errors with, for instance:
curl: (56) response reading failed
curl: (7) Failed to connect to port 21: Operation timed out

There is a notice on

"NOTICE (Updated October 13 2017):
Because of security concerns with plaintext protocols, we still
intend to disable the FTP protocol for downloads on this server
(downloads would still be available over HTTP and HTTPS), but we
will not be doing it on November 1, 2017, as previously announced
here. We will be sharing our reasons and offering a chance to
comment on this issue soon; watch this space for details.
If you maintain scripts used to access over FTP,
we strongly encourage you to change them to use HTTPS instead."

What to do to switch to https as written?

Thanks for pointing this out and sorry for the delay. I’ve just pushed fixed-up modulesets with the correct 
URL for

Thanks John, this gave me the opportunity to dive in jhbuild mechanism (no so deep though ;-)

I've got the error:
 /usr/bin/install -c -m 644 ./html/up.png
Traceback (most recent call last):
  File "/usr/local/xnadalib-2018/bin/gtkdoc-rebase", line 28, in <module>
    from gtkdoc import common, config, rebase
  File "/usr/local/xnadalib-2018/share/gtk-doc/python/gtkdoc/", line 31, in <module>
    import six
ImportError: No module named six
*** Error during phase install of glib: ########## Error running make 
DESTDIR=/usr/local/xnadalib-2018/_jhbuild/root-glib install *** [4/28]

I fixed it with:
$ easy_install -a -d $HOME/Source/jhbuild/jhbuild/sitecustomize six

*** Installing gtk-osx-docbook *** [21/24]
make DESTDIR=/usr/local/xnadalib-2018/_jhbuild/root-gtk-osx-docbook install
sed: RE error: illegal byte sequence
sed: RE error: illegal byte sequence

I didn't fix them, but, they didn't seem to be critical.

*** Checking out gtk-engines *** [17/18]
curl --continue-at - -L -o 
checking for GTK... no
configure: error: GTK+-2.12 is required to compile gtk-engines
*** Error during phase configure of gtk-engines: ########## Error running ./configure --prefix 
/usr/local/xnadalib-2018    *** [17/18]

I haven't found a fix.

Have you an idea?

Thanks, Pascal.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]