Re: [gtk-osx-users] GTK2.x issue on macOS High Sierra

Hi Tom,

thanks again, that indeed solved the issue.



From: Tom Schoonjans <tom schoonjans me com>
Sent: Wednesday, September 6, 2017 1:22 PM
To: Miroslav Rajcic
Cc: gtk-osx-users-list gnome org
Subject: Re: [gtk-osx-users] GTK2.x issue on macOS High Sierra
Hi Miroslav,

It looks like the zlib you bundle with your app is too old as it doesn’t include the recently added symbol inflateValidate, which is used by recent versions of libpng (like the one that ships with High Sierra).

You will need to rebuild zlib and include the new dylib in your app.



On 5 Sep 2017, at 11:11, Miroslav Rajcic <mrajcic hotmail com> wrote:


one of the users reported that my program (bundling GTK2.24.31, built using gtk-osx project) won't start
on macOS High Sierra.
He managed to get it started by clicking on the binary itself (of course, it was not usable), but not through the launcher script (program would not start).
After instructing him to try to run the launcher script from the terminal, he could see these errors:

The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist
dyld: Symbol not found: _inflateValidate
   Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libPng.dylib
   Expected in: /Applications/ in/System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libPng.dylib
Abort trap 6

App was bundles GTK in 32-bit mode (stable module set), built using (ancient) XCode 4.2 to ensure compatibility with users having OS X 10.6.

Just for a test, user tried to fetch the latest launcher script, but that one failed as well.

Is this a known issue? Any pointers on how to resolve this?


Gtk-osx-users-list mailing list
Gtk-osx-users-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]