[gtk-osx-users] Correct way to build a 10.8+ compatible GTK version with xcode8

Hi guys,

I recently updated to 10.12 and xcode8, I've seen that this version of xcode does not allow the use of older SDKs.

I've tried to add a 10.8 SDK inside xcode8 bundle, extracted from xcode5, and to specify in .jhbuild-custom:

setup_sdk(target="10.8", sdk_version="10.8", architectures=[_default_arch])

... but jhbuild failed on the bootstrap stage at the first package, since it seems that the newer clang compiler is unable to build working code with older sdks...

So I tried to specify only target 10.8 and to compile link with the default SDK:

setup_sdk(target="10.8", sdk_version="10.12", architectures=[_default_arch])

... I've seen simpler projects work flawlessy on older versions of OSX simply with MACOSX_DEPLOYMENT_TARGET=10.8

... the compilation worked successfully till glib when it failed on gobject-introspection (please note that those messages seems to be "mixed", maybe cause they are the mixed outputs of different threads):

dyld: lazy symbol binding faileddyld: lazy symbol binding failed: Symbol not found: _g_cocoa_notdyld: lazy symbol binding failed: Symbol not found: _g_cocoa_notdyld: lazy symbol binding failedification_backend_get_type

nst/lib/libgio-2.0.0.dylib  Experenced from: /Users/gabry/gtk/idyld: Symbol not found: _g_cocoaected in: flat namespace

nst/lib/libgio-2.0.0.dylib  Expdyld: Symbol not found: _g_cocoa_notification_backend_get_type


What's the correct way to compile GTK+ to be compatible with older OSX releases?

I have to install and use the compiler provided by an older Xcode version (5 in this scenario)?

In that case there is a way to tell jhbuild to use the older xcode version or I have to use xcode-select from the command line before "bootstrap"?


PS: obviously I can compile without errors with target/sdk 10.12

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]