[gtk-osx-users] 10.11 bootstrap and python2 problems

I've successfully used gtk-osx on 10.9 to build and bundle a gtk+python
application and have now updated to 10.11 and I'm facing various problems.

First jhbuild bootstrap fails complaining about bash not being there. I guess
this is due to the SIP workaround in jhbuildrc-gtk-osx [0], but I can't see
how this can work during bootstrap as the modules there never contain
"bootstrap". I've worked this around for now by unsetting CONFIG_SHELL in my
jhbuildrc if the CONFIG_SHELL path does not exist.

The second problem is python2 fails to build correctly. It complains about
zlib/bz2 missing after make is finished and I'm also hit by the libxml2
linking problem [1] which was reported on gtk-osx-devel-list. I've also tried
building Python 2.7.11 instead but I get the same results.

[0] https://git.gnome.org/browse/gtk-osx/tree/jhbuildrc-gtk-osx#n368
[1] https://mail.gnome.org/archives/gtk-osx-devel-list/2014-December/msg00016.html

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]