Re: [gtk-osx-users] GTK-OSX and Webkitgtk Question

On May 29, 2014, at 4:44 PM, Tony Kubalak <apk uwalumni com> wrote:


My name is Tony Kubalak and I am software developer trying to add webkitgtk to an application that 
currently uses gtk-osx as generated by jhbuild.

I got your name from some of the many websites I have searched trying to solve my problem.  I would like to 
ask you a couple of questions if that is okay.  If it is not okay you can skip the rest of this note.

I built have and am successfully using gtk-osx linked with my application.  I used the jhbuild procedure 
outlined on the website, Building.  I now want to incorporate webkitgtk.  I ran "jhbuild build webkit".  
Much to my surprise this completed successfully and I was able to link my program with it.  When I ran the 
program the raw html was displayed and not the rendered version.  I also got the following critical lib 
soup error: 

libsoup-CRITICAL **: soup_session_send_request_async: assertion 'use_thread_context' failed

I am using libsoup-2.4.1.dylib and libwebkit-1.6.1.dylib.

I have researched this problem and tried many different things, but nothing I do makes a difference.  I 
pulled the libraries from   gnu cash because according to my research this uses the libwebkitgtk and 
libgtk-quartz.  Unfortunately these are built with a 32 bit architecture and mine is x86-64.  So I 
downloaded gnucash-2.6.3 and tried to see if I could build it for x86-64.  I used macports to bring in 
packages that it said that I needed.  When I ran "configure --disable-dbi" I got the following error 
"Cannot find Glib Gettext".  I used macports to install gettext and I can see there is 

This was just one of my many attempts to get my program to render html properly.

I was wondering if you had any thoughts on how to get rid of the libsoup problem or anything else to get a 
compatible set of libraries that will work with libgtk-quartz and libwebitgtk.  I am also a little 
concerned with the older version of webkit because my program is running successfully on linux and Windows 
using libwebkitgtk-1.10.2.

My mac is running Lion.

I appreciate any ideas or thoughts you might have and thanks for your time.

Please subscribe to and use the gtk-osx-users mailing list. I’ve CC’d the list for your convenience and to 
get your original questions on the list.

Your seem to be ignoring the very prominent warning on 
Mixing Fink or MacPorts and GTK-OSX will fail.

If you insist on having MacPorts on your system for some perverse reason, the easiest thing to do is to 
create a separate user for gtk-osx; otherwise you’re in for shell hackery to hide the MacPorts paths and 
other environment variables so that gtk-osx can’t see anything that MacPorts installed or built.

The older version of WebKitGtk is because the WebKitGtk folks don’t want to support quartz, so all of their 
anti-quartz ifdefs, most of which are gratuitous simply to prevent WebKitGtk from compiling with quartz, have 
to be patched around. It’s a lot of work and the result is rather brittle, so it has to be redone for every 
version. 1.6.8 is sufficient for GnuCash’s needs so I don’t have much motivation to upgrade for the sake of 

If you want to build GnuCash with gtk-osx, use

Maybe the way you’re passing the html pages to WebKit works in 1.10 but not in 1.6. The gnucash code for that 
is in src/html; maybe there’s something there that can help you sort out why your code doesn’t work. I didn’t 
write that bit and haven’t ever looked at it, so I can’t really offer much more help than that.

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]