Re: [gtk-osx-users] install_name_tool error when bundling

On Mar 25, 2013, at 7:16 AM, cch (english) <cch heonium com> wrote:


I try to bundle a pygtk application on mac osx lion mountain with gtk-mac-bunbler and when i run it the 
following error appear. Seeing this I try bundler the demo app and I get the same error.

Does anyone have a working track to solve this problem.

install_name_tool: can't open input file: 
/Users/gtkosx5/Desktop/ for writing (Permission 
install_name_tool: can't lseek to offset: 0 in file: 
/Users/gtkosx5/Desktop/ for writing (Bad file 
install_name_tool: can't write new headers in file: 
/Users/gtkosx5/Desktop/ (Bad file descriptor)
install_name_tool: can't close written on input file: 
/Users/gtkosx5/Desktop/ (Bad file descriptor)

thank you very much

Yes, it's a permissions issue. Python wrote their makefile to install libpython read-only and the bundler 
needs to change its internal rpaths. Just 
  chmod +w $PREFIX/lib/libpython2.7.dylib
and re-run the bundler.

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]