Re: [gtk-osx-users] Installing gtk on Mountain Lion (10.8.2) fails

I have tried this and get the same set of errors.

After setting up jhbuild all I have done is follow the sequence recommended on the build instructions page:

$ jhbuild bootstrap

$ jhbuild build meta-gtk-osx-bootstrap

$ jhbuild build meta-gtk-osx-core

I haven't knowingly made any platform choices and there does not appear to be anything in my shell variables that mention architectures

Is it possible to check how jhbuild has configured itself?


On 15 Mar 2013, at 14:24, John Ralls <jralls ceridwen us> wrote:

On Mar 15, 2013, at 2:11 AM, Simon Martin <S J Martin lboro ac uk> wrote:

thanks for the helpful comments/suggestions.

I have tried Mike's suggestion of using the SF version of the script and the updated one that John has put in the git repository.

They both seem to run OK and jhbuild seems to work.

Now I get problems with the build process. A few of the parts do not work. If I choose the option to skip over these modules then I get some form of gtk but the pygtk build process appears to need some of these missing parts and fails in a big way.

I have put summaries of the errors that are thrown up below in the hope that someone can spot what is going wrong. It may well be that fixing the first error will make the others go away.

I have the latest Xcode installed and my python is 2.7.2



jhbuild build meta-gtk-osx-bootstrap

*** Installing gtk-osx-docbook *** [2/15]
make install
sed: RE error: illegal byte sequence
sed: RE error: illegal byte sequence

   import libxml2mod
ImportError: dlopen(/Users/simonmartin/gtk/inst/lib/python2.7/site-packages/, 2): no suitable image found.  Did find:
/Users/simonmartin/gtk/inst/lib/python2.7/site-packages/ mach-o, but wrong architecture
make[2]: *** [de/gnome-doc-make.xml] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1
*** Error during phase build of gnome-doc-utils: ########## Error running make   *** [9/15]

Don't skip. There's nothing in the build that you don't need.

The problem seems to be that you've somehow built some packages with one architecture (the choices being x86_64 and i386) and are trying to build later packages with the other one. The easiest thing to do is to delete /Users/simonmartin/gtk and start over.

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]