Re: [gtk-osx-users] Can't shell jhbuild on Mac OS X Mavericks (10.9)

On Dec 17, 2013, at 11:41 AM, Måns Nilsson <mans_nilsson_65 hotmail com> wrote:

Hello again.

I re-downloaded the file and re-ran the "sh" and 
"~/.local/bin/jhbuild shell" commands. That worked well. However, when I then run the "jhbuild bootstrap" 
command, I eventually get stuck on the following error message: "*** Error during phase configure of 
pkg-config: ########## Error running ./configure --prefix /Users/test-anvandare/gtk/inst --libdir 
'/Users/test-anvandare/gtk/inst/lib'    *** [11/19]". I've tried all options I'm given, but none of them 
work. I can't skip this error either. A quick Google search suggests that I may have gotten a bad download. 
Is that possible? If so, how can I avoid it happening again?

Also, do I only need to run the "jhbuild bootstrap" command before running the "jhbuild build python" 

Please remember to copy the list on all replies: Use “reply all” (the double-arrow button if you’re using Mac 

Another error in that pkg-config extra_env, fixed now.

I’ll warn you in advance that wget will fail to download intltool, and tell you that the solution is to use 
selection 4 to start a shell and to follow the instructions in the error message, then to quit the shell and 
select 1, rerun checkout.

After running jhbuild bootstrap, jhbuild is best able to optimize the build order if you tell it all of the 
modules that you want built on one line.

All of that said, the fact that you weren’t able to figure out the problem with pkg-config on your own 
suggests that gtk-osx is a bit beyond your level of expertise. 

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]