Re: [gtk-osx-users] [gtk-osx-devel] Previous method for building gtkmm3

On 10/21/2012 04:30 PM, John Ralls wrote:
On Oct 21, 2012, at 3:58 PM, Jim Charlton <jim jimc dyndns org> wrote:

On 10/21/2012 02:36 PM, John Ralls wrote:
On Oct 21, 2012, at 2:13 PM, Jim Charlton <jim jimc dyndns org> wrote:

On 10/21/2012 12:43 PM, John Ralls wrote:
On Oct 21, 2012, at 9:35 AM, Jim Charlton <jim jimc dyndns org> wrote:

Here is my previous method for building gtkmm3 on LION

jhbuild bootstrap --skip libiconv
edited .jhbuildrc to change modulesets-stable to modulesets-unstable
Don't edit .jhbuildrc. You can set moduleset = foo (with whatever value of foo you like) in .jhbuildrc-custom.

added os.environ["ARCHFLAGS"] = "-arch x86_64" to .jhbuildrc-custom
jhbuild build meta-gtk-osx-bootstrap
jhbuild build meta-gtk-osx-gtkmm (it will halt on errors)
independently build/install mm-common and meta-gtk-osx-freetype and put a link between .../gtk/inst/lib/freetype and .../freetype2.
Since you're building from unstable, and so using Pango git master, you shouldn't need Freetype anymore. I (just) added mm-common as a dependency of libsig++, so you won't need to build it after I push the commit.

jhbuild build --skip=atk-bridge gtk+-3.0
Probably better to build meta-gtk-osx-gtk3. The atk-bridge module has been removed, and the gtk3 module's autogen-args includes "--without-atk-bridge", the "skip" isn't needed.

got atkmm-2.22.6.tar from and unpacked it, started a jhbuild shell and ./configure,  make, make install
I've just added that to the  moduleset as well.

continue building meta-gtk-osx-gtkmm

That worked a few months ago and I never got the gobject-introspection error.

I will try again from scratch and see how it now works.
Better to wait a little while, I'm testing my additions to the moduleset and I'll push it when I'm done.

John Ralls

Thanks John:  Do I still need to do 'jhbuild boostrap --skip libiconv' or is the --skip no longer needed?  Can you make meta-gtk-osx-gtk3 a dependency of meta-gtk-osx-gtkmm so it does not have to be built independently?  I will hold off until you make your changes.  What is the status of the gtkmm3 package in modulesets-stable?  Is it similar to meta-gtk-osx-gtkmm in modulesets-unstable?  They have similar dependencies.  I tried it some time ago without success but I never worked on it long.

Please keep the discussion on the list. "Reply All" helps a lot.

I've taken libiconv out of unstable.

No, gtk+ and gtk+-3.0 need to be soft dependencies of gtkmm so that it can be built on top of either one. That requires that you include it in your build-list. (At least I think so… I'm trying that now.) Note that you can set up the whole thing in .jhbuildrc-custom so that all you have to type is `jhbuild build` .

I've pushed the changes, so it should build OK for you now.

It look like I had a misunderstanding about gtkmm versions being linked to particular versions of gtk. It's equally possible that it's *now* that I misunderstand… I'll get it sorted this week.

John Ralls

Hmmmm.  Dang.  I thought that I had replied to the list as well.  I will try to do so in the future.
The proof of the pudding... and all that.  I will give it a try and report back.  I will build meta-gtk-osx-gtkmm in "modulesets-unstable" and build gtk+-3.0 when it needs it.
And after saying that I sent it to the wrong list, and then had to subscribe you. Oh well, it really belongs in the user list anyway.

My gtk2 build completed happily, so I'll fix up stable to have only the one module.

You don't need to build gtk+-3.0 "when it needs it". Just add it to the command line
  jhbuild build meta-gtk-osx-gtk3 meta-gtk-osx-gtkmm
Or, like I said earlier, put the line
  modules = "meta-gtk-osx-gtk3 meta-gtk-osx-gtkmm"
in .jhbuildrc-custom, then you only have to type
  jhbuild build

John Ralls
Hmmmmm... While building meta-gtk-osx-gtkmm I get the following error during build of cairomm. I have seen this before. Can' t remember when and why...

In file included from ../cairomm/surface.h:37,
                 from ../cairomm/context.h:24,
../cairomm/fontoptions.h:151: error: 'FcPattern' has not been declared
In file included from ../cairomm/context.h:25,
../cairomm/fontface.h:477: error: 'FcPattern' has not been declared
../cairomm/fontface.h:481: error: expected `)' before '*' token
make[2]: *** [context.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
*** Error during phase build of cairomm: ########## Error running make *** [24/31]

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]