Re: [Gtk-osx-users] gtk-doc and XML files

On May 27, 2011, at 3:47 AM, Dwayne Bailey wrote:

> On 2011-05-26 21:14, John Ralls wrote:
>> On May 26, 2011, at 3:08 AM, Dwayne Bailey wrote:
>>> Hi,
>>> I get this configure error when building gtk-doc.
>>> checking for XML catalog (/Users/dev/gtk/inst/etc/xml/catalog)... found
>>> checking for xmlcatalog... /Users/dev/gtk/inst/bin/xmlcatalog
>>> checking for DocBook XML DTD V4.3 in XML catalog... found
>>> checking for DocBook XSL Stylesheets in XML catalog... not found
>>> configure: error: could not find DocBook XSL Stylesheets in XML catalog
>>> *** Error during phase configure of gtk-doc: ########## Error running
>>> ./configure --prefix /Users/dev/gtk/inst --libdir
>>> '/Users/dev/gtk/inst/lib' --disable-scrollkeeper
>>> --with-xml-catalog=$JHBUILD_PREFIX/etc/xml/catalog --disable-static  ***
>>> [3/3]
>>> This one is new for me. I've had a lot of stuff that I haven't been
>>> building from scratch, but I tried a clean build and got the error.
>>> My suspicion is that the gtk-osx-docbook-1.0.tar.gz needs a refresh but
>>> I'm not sure where the files in that bundle come from.  Seems like the
>>> only changes to gtk-doc where in Feb this year, seem odd that no one
>>> else has bumped into this one.
>> That is odd indeed. There's no reason to change gtk-osx-docbook: That stuff hasn't changed in many years. What's more likely is that your installation of it broke somehow.
>> The file that xmlcatalog should return is $PREFIX/share/xml/docbook/stylesheet/nwalsh/html/chunk.xsl; the catalog file that it needs to find it is $PREFIX/etc/xml/docbook-xsl.xsl.
>> I'm at an absolute loss to explain what might have gone wrong with your installation of gtk-osx-docbook, since it's obviously partly there (xmlcatalog found docbook-xml.xml, the other catalog configure was looking for).
> It solved itself.  I wish I could tell you how!
> I eventually did another botstrap rebuild with --force then gtk-osx just 
> started working :(

Ah. I think you mean a jhbuild build --force meta gtk-osx-bootstrap. That would have reinstalled a fresh gtk-osx-docbook, repairing the apparent damaged installation.

Good that everything's working now.

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]