Re: [Gtk-osx-users] Failure while building gtk+

On Sep 14, 2010, at 11:43 PM, Richard Procter wrote:

> On 15/09/2010, at 3:09 PM, John Ralls wrote:
>> On Sep 14, 2010, at 5:54 PM, Phillip Heller wrote:
>>> John,
>>> Thanks for that, I've now gotten through the gtk+ build no problem.
>>> However, I've encountered another new failure (which I didn't see  
>>> on the same build on the laptop a few weeks back...), in pygobject:
>>> bank-argument.c: In function 'pyg_argument_from_pyobject':
>>> bank-argument.c:46: error: 'GI_TYPE_TAG_UINT' undeclared (first  
>>> use in this function)


>> Hmm. I just built meta-gtk-osx-python and it went through without  
>> error. Maybe you need to blow away your source directories and  
>> start fresh.
> I've just hit the same error on OS X 10.5 / i386. It was a fresh  
> build, using existing package downloads. Apart from using a local  
> python build (_gtk_osx_use_jhbuild_python = True) and a custom  
> moduleset added to the 'moduleset' list, it's verbatim.
> The symbol GI_TYPE_TAG_UINT looks as if it should be declared by  
> gobject-introspection in girepository/gitypes.h . That file has a  
> note that "These were removed and no longer appear in the typelib".
> If it wasn't building fine on John's machine, I'd say it was a  
> dependency issue - pygobject relying on obsolete gobject- 
> introspection defines. Downgrading to gobject-introspection-0.9.2  
> didn't fix things, though.

I've just blown away the source and install paths, and rebuilt from bootstrap only to encounter this same error in pygobject.

Like Richard, I'm also building for 10.5 i386, and have also set _gtk_osx_use_jhbuild_python = True.


Attachment: smime.p7s
Description: S/MIME cryptographic signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]