Re: [Gtk-osx-users] Failure while building gtk+

On Sep 14, 2010, at 8:43 PM, Richard Procter wrote:

> On 15/09/2010, at 3:09 PM, John Ralls wrote:
>> On Sep 14, 2010, at 5:54 PM, Phillip Heller wrote:
>>> John,
>>> make[2]: *** [repo_la-bank-argument.lo] Error 1
>>> A cursory google of this error reveals it might be related to  
>>> gobject-introspection, which does successfully build with jhbuild.
>>> Thoughts?
>>> Thanks again for the help!
>> Hmm. I just built meta-gtk-osx-python and it went through without  
>> error. Maybe you need to blow away your source directories and  
>> start fresh.
> I've just hit the same error on OS X 10.5 / i386. It was a fresh  
> build, using existing package downloads. Apart from using a local  
> python build (_gtk_osx_use_jhbuild_python = True) and a custom  
> moduleset added to the 'moduleset' list, it's verbatim.
> The symbol GI_TYPE_TAG_UINT looks as if it should be declared by  
> gobject-introspection in girepository/gitypes.h . That file has a  
> note that "These were removed and no longer appear in the typelib".
> If it wasn't building fine on John's machine, I'd say it was a  
> dependency issue - pygobject relying on obsolete gobject- 
> introspection defines. Downgrading to gobject-introspection-0.9.2  
> didn't fix things, though.

Based on the date-stamps of the two packages, you'd probably have to go back to gobject-introspection-0.6.5. It probably makes more sense to upgrade pygobject to 2.21.5 -- which will undoubtedly requirea newer rev of pygtk, as well. I'll do that in the moduleset tomorrow; in the meantime, one or both of you can try it out manually.

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]