Strange behaviour of GTK-3 on separate screens


I've just made a fresh installation of Debian 8 on a dell notebook I use
at work on a docking station.

I use fluxbox and since I work a lot with Ruby on Rails and Django, I
like to have a web browser on the left screen and my code on my right
screen. I configured my X server so that both screens run more or less
independent from each other, that means that my left screen stays on a
workspace while I can change the workspace on the right screen. My
server layout look like this (see the attached xorg.conf)

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

I don't like icedove and iceweasel so I installed firefox & thunderbird
from the websites. I like to have my thunderbird on my right screen.

After the installation I noticed this strange behaviour:

On my right screen I have thunderbird running, on my left I have a
mate-terminal running vim. I had to make copy&paste from an email so I
selected the text and then on the left screen I pressed the middle mouse
button but the text was not pasted. If I press the middle mouse button
on a mate-terminal on the same screen as where thunderbird is running,
the text is pasted as expected.

Then I seletced the text in thunderbird again and pressed Ctrl+C to use
the CLIPBOARD clipboard instead of PRIMARY. Then I tried to make a right
click on the mate-terminal but the menu with the "Paste" option didn't
appear. I tried that a couple of times with the same result. I also
tried to paste on other programs and the result the same: the context
menu did not appear. Then I closed thunderbird and all of a sudden the
mate-terminal showed me the context menu from the right click.

I started thunderbird again and I selected the text but did not press
Ctrl+C. On the mate-terminal I made a right click and I was able to see
the context menu. So then I went back to thunderbird and pressed Ctrl+C
again and then strange behaviour happend again.

Long story short: I started suspecting that GTK3 and the CLIPBOARD
clipboard cause some problems on a separate screen. I tried other gtk3,
gtk2 and QT apps and I was always able to reproduce this behaviour with
the gtk3 apps. The reason why I suspect that it has something to do with
the clipboard is that at some point I started xclipboard to monitor what
GTK3 apps are writing on the clicpboard. With xclipboard running I
wasn't able to reproduce the behaviour again (although pasting from
PRIMARY still doesn't work). Another clue was that when I was
experiencing the problems with the right click, I made a right click on
the desktop and I got the context menu. In fact if the context menu does
not have a "Copy/Paste" option, it was displayed without problems.

Can somebody with a similar X11 setup reproduce this behaviour?

I found this perhaps
there is some configuration flag I could use to prevent this.

What could be the issue here?

Best regards

Pablo Yanez Trujillo
My public key:

Attachment: xorg.conf
Description: Text document

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]