A toggled toggle button visually almost indistinct from untoggled

Hi folks.

When I try to run one of my Python applications (http://stromberg.dnsalias.org/~strombrg/hcm.html) using a very recent built of GTK+ (gobject introspection), I get lots of toggle buttons, as expected.

However, when I click one of those toggle buttons, the visual change is almost imperceptible.

The button is actually toggling - it's giving the desired result (a host or command is selected).  It's just hard to tell by looking at it, if the button is toggled or not.

The exact same Python code (version of hcm) gives good toggle buttons if I run it on an older build of GTK / gobject introspection.

I tried changing themes, but that did not appear to help.  I can tell the theme is at least partially engaged, because some of the colors in my app change.  But the toggle buttons still don't look very toggled.

Also, I'm getting a warning when the app starts.  I don't know if it could be related or not, but it is a little pesky.  BTW, this is in an fvwm2 in a VNC session.  The text of the warning is:
** (hcm:31357): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Xlib:  extension "XInputExtension" missing on display ":1".

Does anyone have any suggestions?  I miss being able to tell which buttons I've clicked!

I'm using self-built:

...with CPython 2.7 and CPython 3.[0123456].

BTW,varying the Python interpreter version doesn't appear to make a difference - they all give the excessively subtle toggle button appearance.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]