RE: Gtk+ 3.0 and MS Windows


Thanks for your quick reply! Good to know that Gtk+ 3 is buildable for win32 according to your OpenSUSE link. I don't have OpenSUSE though, but I'll give cross-compiler a try under Ubuntu.

Gcc is on my path otherwise ./configure would finish much earlier.

$ gcc.exe -v
Using built-in specs.
Target: mingw32
Configured with: ../gcc-4.5.0/configure --enable-languages=c,c++,ada,fortran,objc,obj-c++ --disable-sjlj-exceptions --with-dwarf2 --enable-shared --enable-libgomp --disable-win32-registry --enable-libstdcxx-debug --enable-version-specific-runtime-libs --disable-werror --build=mingw32 --prefix=/mingw
Thread model: win32
gcc version 4.5.0 (GCC)

It is just something wrong with command line arguments

$ pwd

$ gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../.. -DG_LOG_DOMAIN=\"Gdk\" -DINSIDE_GD
K_WIN32 -I../.. -I../../gdk -I../../gdk -DG_DISABLE_CAST_CHECKS -mms-bitfields 
-IC:/msys/1.0/local/include/glib-2.0 -IC:/msys/1.0/local/lib/glib-2.0/include -
IC:/msys/1.0/local/include/pango-1.0 -IC:/msys/1.0/local/include/cairo -IC:/msy
s/1.0/local/include -IC:/msys/1.0/local/include/freetype2 -IC:/msys/1.0/local/i
nclude/libpng14 -IC:/msys/1.0/local/include/gdk-pixbuf-2.0 "" -DGDK_COMPILATION
_DEPRECATED -DG_DISABLE_DEPRECATED -g -O2 -Wall -mms-bitfields -MT gdkcursor-wi
n32.lo -MD -MP -MF .deps/gdkcursor-win32.Tpo -c gdkcursor-win32.c  -DDLL_EXPORT
 -DPIC -o .libs/gdkcursor-win32.o
gcc.exe: : No such file or directory


> -----Original Message-----
> From: Maarten Bosmans [mailto:mkbosmans gmail com]
> Sent: Wednesday, March 23, 2011 1:53 PM
> To: Mikhail Titov
> Cc: Gtk+ list
> Subject: Re: Gtk+ 3.0 and MS Windows
> 2011/3/23 Mikhail Titov <mlt gmx us>:
> > Hello!
> >
> > I understand that there is a lot of work still needs to be done for
> Gtk+ 3.0 . However I would like to use some of its functionality now if
> possible. The problem is that I’m using gtkmm and msvc++ to compile my
> code under MS Windows. I wonder about win32 builds of gtk+ 3.0. Is it
> not buildable under MS Windows yet?
> The windows project on the OpenSUSE BuildService has a package for gtk3:
> gtk3&project=windows%3Amingw%3Awin32
> It seems to build correctly. I haven't tried it, but at least the gtk2
> binaries produced by the OBS run great on Windows.
> > I decided to give it a try and build it myself with MinGW and gcc
> (4.5.0), but I got stuck in the very beginning. I used binary
> dependencies/prerequisites available from ftp to satisfy ./configure
> complaints since I had old prerequisites bundle installed. However
> ./configure got stuck saying that I have no cairo_pdf.h, though I can
> see it with ls /usr/local/include/cairo/ . Oh well, I commented out this
> check. When I executed make V=1 I got this:
> >
> > make[5]: Entering directory `/c/workspace/gtk+-3.0.4/gdk/win32'
> > /bin/sh ../../libtool  --tag=CC   --mode=compile gcc -std=gnu99 -
> I../.. -I../../gdk -I../../gdk -DG_DISABLE_CAST_CHECKS -mms-bitfields -
> IC:/msys/1.0/local/include/glib-2.0 -IC:/msys/1.0/local/lib/glib-
> 2.0/include -IC:/msys/1.0/local/include/pango-1.0 -
> IC:/msys/1.0/local/include/cairo -IC:/msys/1.0/local/include -
> IC:/msys/1.0/local/include/freetype2 -
> IC:/msys/1.0/local/include/libpng14 -IC:/msys/1.0/local/include/gdk-
> DG_DISABLE_DEPRECATED -g -O2 -Wall -mms-bitfields -MT gdkcursor-win32.lo
> -MD -MP -MF .deps/gdkcursor-win32.Tpo -c -o gdkcursor-win32.lo
> gdkcursor-win32.c
> > libtool: compile:  gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../.. -
> DG_LOG_DOMAIN=\"Gdk\" -DINSIDE_GDK_WIN32 -I../.. -I../../gdk -I../../gdk
> -DG_DISABLE_CAST_CHECKS -mms-bitfields -IC:/msys/1.0/local/include/glib-
> 2.0 -IC:/msys/1.0/local/lib/glib-2.0/include -
> IC:/msys/1.0/local/include/pango-1.0 -IC:/msys/1.0/local/include/cairo -
> IC:/msys/1.0/local/include -IC:/msys/1.0/local/include/freetype2 -
> IC:/msys/1.0/local/include/libpng14 -IC:/msys/1.0/local/include/gdk-
> DG_DISABLE_DEPRECATED -g -O2 -Wall -mms-bitfields -MT gdkcursor-win32.lo
> -MD -MP -MF .deps/gdkcursor-win32.Tpo -c gdkcursor-win32.c  -DDLL_EXPORT
> -DPIC -o .libs/gdkcursor-win32.o
> > gcc.exe: : No such file or directory
> > make[5]: *** [gdkcursor-win32.lo] Error 1
> It appears that gcc is not in your path.
> > Is it really not ready for win32 at all or am I doing something wrong?
> > All I want at this point is a color selection dialog with transparency
> support and RGBA type instead of Color.
> >
> > Also I’ve tried experimental VS9 project created by configure. But it
> requires “msvc_recommended_pragmas.h” that I gon’t have. Okay, removed
> that one. Also I corrected GlibEtcInstallRoot path and added dash after
> Gdk into include Gdk-Pixbuf-2.0. However this time it is getting stuck
> on GDK_TYPE_CURSOR_TYPE and alike in gdkcursor.c while gdkenumtypes.h
> doesn't contain anything useful as in binary gtk+ 2 I have.
> >
> > What are my options? Is it something I should just wait? When roughly
> do you estimate to have win32 build available (even unstable)?
> In my experience cross-compiling on Linux using the mingw headers is
> _much_ easier than on windows with msys+mingw. I have never tried
> > Mikhail
> Maarten

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]