Missing gtk_widget_set_can_focus, have (_)_gtk_widget_set_can_focus

I'm trying to link the GTK+-2.22 Windows "all in one" binaries with MinGW and I'm getting this when I run my application:

"The procedure entry point gtk_widget_set_can_focus could not be located in the dynamic link library libgtk-win32-2.0-0.dll."

I'm linking to it with `pkg-config --libs gtk+-2.0`.  I ran nm on the .a file and the .lib file, and both list _gtk_widget_set_can_focus. 

When I ran dlltool to create a .a for libsndfile, I had to omit "-U" in order for the symbols to be found.  Running `strings` on the libsndfile.a shows a corresponding underscoreless version of each function.  When I run `strings libgtk-win32-2.0.dll.a | grep gtk_widget_set`, on the other hand, around half of the symbols (lgtk_widget_set_can_focus included) are listed without underscoreless versions.  That seems kind of strange to me, although I won't claim to have any idea what I'm talking about.

Am I making a simple mistake here (or a rather major mistake)?  Or is there a workaround for this?

Thank you very much,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]